Mobile app outage

Incident Report for Carepay

Resolved

This incident has been resolved.
Posted Jul 20, 2026 - 09:07 UTC

Identified

We have identified the issue and we are working on a fix
Posted Jul 20, 2026 - 08:47 UTC

Investigating

We are currently investigating mobile app services outage issue
Posted Jul 20, 2026 - 08:38 UTC
This incident affected: M-TIBA Platform (Mobile App).