Platform downtime - UAE Instance

Incident Report for Carepay

Update

We are continuing to work on a fix for this issue.
Posted Mar 05, 2026 - 11:54 UTC

Update

We are continuing to work on a fix for this issue.
Posted Mar 05, 2026 - 11:53 UTC

Identified

Investigations indicate root cause to be AWS outage in the ME region
Posted Mar 01, 2026 - 16:30 UTC

Investigating

We are currently investigating this issue.
Posted Mar 01, 2026 - 15:30 UTC
This incident affects: UAE (UAE Payer Management, UAE Underwriting, UAE Policy Setup, UAE Policy Enrollment, UAE Provider Management, UAE Case Management, UAE Claims Management, UAE Payments, UAE Mobile App, UAE User Management, UAE Reporting, UAE Business Intelligence).